You can use 4 different methods to spool print jobs when using SecurePrint:
-
Using a driver (Port Monitor) on the PC
-
Sending an email with attached files to a specific email address
-
Uploading a file on the Web UI
-
Using an SDC (Smart Device Connector) on the Smart device
Make sure RSI Control+ Setup is the latest version:
-
If you installed Control+ from the Application Site:
-
If Control+ is not displayed on the update list screen of the application site, Control+ is the latest version.
-
-
If you installed Control+ from Cloud Setting app:
-
Enable automatic updates to make sure you’re using the latest version.
-
To set up SecurePrint, you’ll need to complete the following steps.
-
Complete the SecurePrint prerequisites.
-
Download the driver installer (called Port Monitor).
-
Install the driver.
-
Spool the print job to RSI-Cloud.
-
Retrieve the print job.
-
Upload print jobs using email or web.
-
Upload print jobs using Chrome OS extension.
1. Complete the SecurePrint prerequisites
CPU
According to the specifications recommended for each Operation System
Memory
According to the specifications recommended for each Operation System
Storage
Free space of 500 MB or more
OS and print driver
|
OS |
Print Driver |
|---|---|
|
Windows
|
PCL 6 Driver for Universal Print |
|
Windows (ARM / WPP(Windows Protected Print))
|
|
|
macOS
|
|
|
Google Chrome OS
|
Ricoh Cloud Print extension |
Supported languages
Supported languages: Japanese, English, French, Germany, Italy, Dutch, Spanish, Brazilian Portuguese, Traditional Chinese, Simplified Chinese, and Thai
2. Download the driver installer (Port Monitor)
Port Monitor is a print client you can use for uploading files to the RSI-Cloud Server from the local printer driver.
The protocol used for transmitting the data is HTTPS, and the maximum size you can submit via Port Monitor is 300MB per document (spool size).
This Port Monitor is developed based on the current Flex Release service and set the version v2.0.
You can either:
-
Download a new version of Port Monitor
-
Download an overwrite version of Port Monitor
More guidance is below.
Download a new version of Port Monitor
-
Find the Port Monitor download link on the Common Settings Site.
-
Once you select the link, you’ll be prompted to download a zip file.
-
Download the zip file. The default installation path is
%Program Files Dir%\FRCXport. -
Once you’ve downloaded the zip file, there will be an executable file (.exe) to install the driver.
After downloading Port Monitor onto your device, it will be stored in the PC registry. The path to locate it is HKEY_CURRENT_USER\SOFTWARE\RICOH\FRCX_Port.
Access the logs to troubleshoot Port Monitor
To troubleshoot Port Monitor errors, you’ll need to review the logs.
Logs will automatically generate for troubleshooting purposes and they have a maximum size of 10MB. A new generation is created daily, or when the maximum size has been reached.
To locate the logs:
-
Go to the
<InstallDir>\log directory(logs automatically save here). The location of your log directory will depend on where you downloaded the install, for example:C:\Program Files\FRCX Port\log. -
The file name is
fr_cx_port.log. -
The date in the YYYYMMDD format is appended to the log’s filename, for example [port_error.log.20111207].
Resolve Port Monitor error messages
|
Error codes |
Error message |
Solution |
Available version from |
|
15013222 |
Uploading file size must be up to 300MB |
The file you’re uploading is too big. The file must not exceed 300MB. |
v1.1 |
|
15019999 |
A communication error has occurred. |
When a communication error other than 15019997 or 15019998 occurs. this isn’t v good … how can a user solve this? |
v1.1 |
|
85109999 |
The service is not available. |
There is no query code in the server response or an unknown error has occurred. Contact support to resolve. |
v1.1 |
|
13013310 |
Up to 50 files could be registered. |
You can only register 50 documents at a time. |
v1.1 |
|
13011005 |
You do not have the authority to use the service. |
You do not have the right to use the service (without license). Contact Support if you need help. |
v1.3 |
|
13011006 |
You do not have the authority to use the service. |
You do not have the right to use the service. Contact Support if you need help. |
v1.3 |
|
* |
Failed to upload the file. |
An error has occurred in Cirrus-S. Contact support to resolve. |
v1.1 |
|
15019000 |
Failed to upload the file. |
An internal error has occurred during document registration. Try registering the document again. |
v1.1 |
|
15019998 |
Not connected to the network. |
You’re not connected to the network. Check your network settings and try again. |
v1.1 |
|
15019997 |
A timeout has occurred. |
A timeout has occurred. Please try again. |
v1.1 |
|
* |
Failed to login. Contact the administrator. |
The login has failed. Contact Support. |
v1.4 |
|
15013103 |
Log on again to Windows as a domain user. |
The "Use Windows logon information" box is checked but you are not logged on as a domain user. Log on as a domain user and try again. |
v1.4 |
|
95010001
|
A system error has occurred. |
Failure for Microsoft 365 authentication. Contact support to resolve. |
v2.0 |
|
95010002 |
A system error has occurred. |
Failure for Microsoft 365 authentication. Contact support to resolve. |
v2.0 |
|
95010003 |
A system error has occurred. |
An error of incorrect parameter is occurring. Contact support to resolve. |
v2.0 |
|
* |
Failed to log in. Invalid login information or locked account. Please try again or contact your administrator. |
Failure for Microsoft 365 authentication. Contact support to resolve. |
v2.0 |
Uninstall Port Monitor
You should not perform uninstallation if there are spooled print jobs, otherwise the spooled jobs might not complete.
Uninstallation deletes all the configuration information. For v2.3 or later, user information stored in the paths below will not be deleted automatically, even after the uninstallation.
-
HKEY_CURRENT_USER\SOFTWARE\RICOH¥FRCX_Port -
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
If needed, user information should be deleted manually by executing the batch files placed in the following path. Run the batch file using this Command prompt: %Installed folder path% \FRCX port\tool\fr_cx_port_regmsclear.bat
You can uninstall by:
-
Making sure you have administrator privileges.
-
Going to the control panel on the MFP.
-
Go to the Program Uninstall menu.
3. Install the driver
Now you’ve downloaded Port Monitor, you’ll need to install the driver depending on your OS:
Download installer
There are two ways to access the download page, but both provide the same installer for download.
-
Access RSI Portal Site.
-
If Admin mode is enabled, turn it off from the top-right corner of the screen.
Download from Application Settings
-
Click Application Settings(General Users).
-
Click Download.
-
Click Printer Driver for Cloud Printing.
Download from FlexRelease
-
Click FlexRelease CX.
-
Click Printer Driver.
Windows (PCL 6 Driver for Universal Print)
To install a printer driver for cloud printing, administrator privileges are needed.
-
Access the download page from a PC browser.
-
Select the installer to download.
-
Run the .exe file and follow the on-screen instructions to install.
Windows (PSA: Print Support Application)
-
Access the download page from a PC browser.
-
Click the Download from Microsoft Store button.
When Downloading from the Microsoft Store application
-
Click View in Store.
-
Click Get and installation will start automatically.
-
The printer driver (printer icon name: RSI Cloud Printer) and application (Ricoh
Cloud Print) are installed.
When Downloading from the Microsoft Store website
-
Click Download.
-
Run the .exe file and follow the on-screen instructions to install.
-
The printer driver (printer icon name: RSI Cloud Printer) and application (Ricoh
Cloud Print) are installed.
macOS (Ricoh PS Setting)
-
Access the download page from a PC browser.
-
Select the installer to download.
-
Run the .dmg to install.
-
If you are using a proxy server, check "Use a Proxy Server" and configure the
proxy server settings.
-
Enter your credentials into "Login", and then click “Install”.
-
The printer driver is installed.
Resolve errors for driver installation for Mac OS
|
Error message |
Solution |
|
Failed to connect to the server, please check the network settings. |
Check the network settings. |
|
Please enter a port name. |
Server port is empty. Fill in the server port name. If you’re unsure, contact your administrator. |
|
Server Port Error |
Server port setting is incorrect. Recheck the details and fill it in again. |
|
Please enter a proxy port name. |
When using a proxy server, the port is empty. If you’re unsure, contact your administrator. |
|
Proxy Port Error |
When using a proxy server, the port setting is incorrect. If you’re unsure, contact your administrator. |
|
UID Error |
The authentication user ID is invalid. Check your user ID details are correct. |
|
Please enter a UID |
The authentication user ID is empty. Fill in your authentication user ID. |
Google Chrome OS
You can add Ricoh Cloud Print using Chrome extensions.
-
Access to chrome web store, and then search Ricoh Cloud Print.
-
Click displayed Ricoh Cloud Print.
-
Click Add to Chrome.
-
Click Add extension.
Ricoh Cloud Print has been added to Extentions.
4. Spool the print job to RSI-Cloud
-
Start up the operating system.
-
Load the first print job spool.
-
You’ll see a user login window pop up. This will contain different information, depending on the user authentication method.
-
Email address authentication:
-
Check the box to save user information.
-
RSI User info will now cache in the cloud. The authentication popup is not displayed even after restarting the client PC.
-
-
O365 account authentication:
-
Check the box to save user information.
-
You’ll see an authentication popup where you can enter user information.
-
-
Tenant ID / Password authentication:
-
Check the box to save user information.
-
RSI User info will now cache in the cloud. The authentication popup is not displayed even after restarting the client PC.
-
-
Set a billing code
When spooling a print job to RSI-Cloud, you may want to set a billing code.
-
On your device, open the RSI Cloud Printer Properties application.
-
Select Job Type/Code Dialog Settings.
-
Check the Display [Classification Code] Dialog Before Printing box.
-
Press OK at the bottom of the dialog box.
Now when spooling a print job, a dialog pop-up box will appear where you can enter the billing code.
Resolve errors for spooling a print job to RSI-Cloud
|
Error |
Solution |
|
Failed to login. Check the authentication information is correct. |
Login with saved credentials has failed. This occurs if:
|
5. Retrieve the print job
There are two types of applications to retrieve the spooled print jobs and output from printers.
-
SOP app (newer and faster print capacity)
-
SI-Launcher app (conventional)
Retrieve and delete the print job using SOP app
You can select up to 100 print jobs at the same time
-
Use your administrator credentials to log in to the MFP and you’ll see the job list.
-
Check the row of the individual job(s) or select SELECT ALL. If you want to delete the print job after execution:
-
Select CHANGE (after you have selected the jobs).
-
Select Delete after Printing option.
-
Select the Delete option. The default setting is Delete.
-
-
Select START.
-
The jobs will start printing.
To access print settings on the SOP app, select the jobs and then select the CHANGE button on the right hand side. This will navigate you to the print settings where you can adjust:
-
Print colour mode
-
Quantity (minimum 1)
-
1 or 2 sided (Short /Long edge bind)
-
Designate page
When a problem such as no paper or print size mismatch occurs, the device status stays as Error. In this case, the device (and not RSI-Cloud) controls the print job or screen until the problem is solved.
Retrieve and delete the print job using SI-Launcher app
You can select up to 100 print jobs at the same time
-
Log in to Flex Release Print app and you’ll see the job list.
-
Check the boxes in front of the job(s) (you can either print these jobs or select Print Settings to adjust the settings). If you want to delete the print job after execution:
-
Select the > arrow which appears on the right once you have selected the jobs to print.
-
You’ll be navigated to a window where you can select Yes or No for the option to delete the print job after execution. The default is Yes.
-
-
Select Start.
-
The jobs will start printing.
To access print settings using the SI-Launcher app select the jobs and then select the Print Settings button on the right hand side. This will navigate you to the print settings where you can adjust:
-
Print color mode
-
Quantity (minimum 1)
-
1 or 2 sided (Short /Long edge bind)
When a problem such as no paper or print size mismatch occurs, the device status stays as Error. In this case, the device (and not RSI-Cloud) controls the print job or screen until the problem is solved.
6. Upload print jobs using email or web
You might want to upload a print job by sending it using email or web upload settings.
RICOH supports this using an application called FlexRelease CX (FRCX).
There are different methods, depending if you’re:
-
Uploading print jobs using email or web as an administrator
-
Uploading print jobs using email or web as a non-administrator
Upload print jobs using web as an administrator
-
Go to the RSI portal.
-
Make sure the Admin Mode toggle on the page header is turned on.
-
Go to FlexRelease CX app in the application settings.
-
Select the URL in the External Service URL.
-
Make sure you’re in Upload File on the left-hand navigation.
-
Select Choose File.
-
Upload the file you want to print.
Upload print jobs using email as an administrator
-
Go to the RSI portal.
-
Make sure the Admin Mode toggle on the page header is turned on.
-
Go to FlexRelease CX app in the application settings.
-
Select the URL in the External Service URL.
-
Make sure you’re in Email Print Settings on the left-hand navigation.
-
Copy the email address. This is the email address for sending a document with FlexRelease CX.
-
Send an email to the address above.
Upload print jobs using email as an administrator
-
Go to the RSI portal.
-
Make sure the Admin Mode toggle on the page header is turned on.
-
Go to FlexRelease CX app in the application settings.
-
Select the URL in the External Service URL.
-
Make sure you’re in Email Print Settings on the left-hand navigation.
-
Copy the email address. This is the email address for sending a document with FlexRelease CX.
-
Send an email to the address above.
Upload print jobs using web as a non-administrator
For web upload (maximum size of file is 40MB, with a supported file format: msg, pdf, txt, ipg, png, gif, tif). You have 2 methods of uploading:
-
upload to web using FRCX portal:
-
[Go to the FRCX portal](https://eu.start.ricoh.com/frcx-portal/clear_ticket) and select Upload File settings.
-
Select Choose File above the table.
-
Select the file you want to upload and adjust the settings needed.
-
Select Upload.
-
-
upload to web using RSI portal:
-
Go to the RSI portal. Make sure the Admin Mode is turned off (check the toggle at the top-right hand side).
-
Go to FlexRelease CX app.
-
Make sure you’re in Print Job List on the left-hand navigation.
-
Select + Add File button above the table.
-
Select the file you want to upload and adjust the settings needed.
-
Select OK.
-
Upload print jobs using email as a non-administrator
For email upload (maximum size of email is 30MB, with a supported file format: msg, pdf, txt, ipg, png, gif, tif):
-
Go to the RSI portal.
-
Make sure the Admin Mode toggle on the page header is turned off.
-
Go to FlexRelease CX app.
-
Open the Email Attachment Print Settings on the left-hand navigation.
-
Copy the displayed email address (this will look similar to f.3043382658@ft.frcx.ricoh.com).
-
Paste this email address into the To field on an email.
-
Attach the document you want to upload.
-
To adjust settings, select Email Attachment Print Settings button above the table.
7. Upload print jobs using Chrome OS extension
You can upload print jobs using a Chrome OS extension. This feature is currently only available in RICOH Europe.
-
Download the RICOH Chrome extension:
-
Go to the Chrome Web Store RICOH page.
-
Select the RICOH Cloud Print extension.
-
Select the Add to Chrome button.
-
-
Configure authentication:
-
Select your RICOH Cloud Print extension.
-
Go to Auth Settings.
-
Select your authentication type (Tenant ID, email and O365 are supported).
-
Select Login.
-
-
Spool Chrome print job to RSI Cloud:
-
Go to the three vertical dots at the very top right of your screen on the Chrome browser.
-
Select Print setting.
-
The print preview screen will open.
-
Select RICOH Cloud Print from the destination list.
-
Select Print.
-
If the job spool fails, an error message will display.
-
You can check if the spool was successful by going to Application Settings on the Common Settings Site.
You’ll see all jobs spooled in the Job List tab.
Set up direct printing
You can print documents directly from the enterprise system, for example SAP, Oracle.
-
Open Printer properties > Advanced Options tab > User Authentication.
-
Set User Authentication to On.
-
Go to Printer properties > General tab > Basic Setting > Basic tab > Authentication.
-
Enter Login User Name and Login Password for RSI authentication.
-
Go to Printer properties > Ports tab.
-
Choose Standard TCP/IP Port as Printer Port.
Add exception pages when printing
Exception pages have different settings from the rest of the pages in the job. For example:
-
Different page colour
-
Different page type
You can create multiple exceptions for each print job. You can set exception pages in SOP or Web Image Monitor (WIM). A WIM will allow you to interact with a device from a webpage.
Set exception pages in SOP
-
Go to System Settings > Settings for Administrator > Authentication/Charge(Only smart settings) > Administrator Authentication/User Authentication/App Auth(Only smart settings) > User Authentication Management > Basic Authentication > Printer Job Authentication.
-
Choose Simple(Limitation) and specify the IP range of the core system to Limitation Range.
Set exception pages in WIM
-
Login to WIM as an administrator and go to Device Management > Configuration > User Authentication Management > Basic Authentication > Printer Job Authentication.
-
Choose Simple(Limitation) as Printer Job Authentication and set Limitation Range.